re = /[^(\x20-\x7F\n)]+/
str = 'Punjab me 1Train🚊 k niche 100 👳Sardar aa gaye..
99 Mar gaye...
1 Bach gaya'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result