import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.\\K\\h*[Jj]ack,? is[^.\\n]*\\.$";
final String string = "Jack is the tallest person.\n"
+ "and Jack is the one who said, let there be fries.\n"
+ "There are mirrors. And Jack is there to be suave.\n"
+ "There are dogs. And jack is there to pat them. Very cool.\n"
+ "Jack is your lumberjack. Jack, is super awesome.\n"
+ "Whereas Jack is, for the whole summer, sound asleep. Zzzz\n"
+ "'Jack is so cool!' Jack is cool. Jack is also cold.";
final String subst = " [TRIM]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}