import Foundation
let pattern = #"\.\K\h*[Jj]ack,? is[^.\n]*\.$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Jack is the tallest person.
and Jack is the one who said, let there be fries.
There are mirrors. And Jack is there to be suave.
There are dogs. And jack is there to pat them. Very cool.
Jack is your lumberjack. Jack, is super awesome.
Whereas Jack is, for the whole summer, sound asleep. Zzzz
'Jack is so cool!' Jack is cool. Jack is also cold.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" [TRIM]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)