const regex = /\.\K\h*[Jj]ack,? is[^.\n]*\.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.\\K\\h*[Jj]ack,? is[^.\\n]*\\.$', 'gm')
const str = `Jack is the tallest person.
and Jack is the one who said, let there be fries.
There are mirrors. And Jack is there to be suave.
There are dogs. And jack is there to pat them. Very cool.
Jack is your lumberjack. Jack, is super awesome.
Whereas Jack is, for the whole summer, sound asleep. Zzzz
'Jack is so cool!' Jack is cool. Jack is also cold.`;
const subst = ` [TRIM]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);