#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<event>^.\S*[^\n<]*(?:(?:<(?!)|\n(?!$))[^\n]*)*(?:|\n$|\z))"
Local $sString = "isDraggingObject : True" & @CRLF & _
"id : afbbdeb7-9fd4-4b53-ab17-742809154ba9" & @CRLF & _
"condition : {or, matches System.Object[] (?i)(^.*?host failure " & @CRLF & _
" alert.*?www\.jennycraig\.com\.au.*?$), matches System.Object[] " & @CRLF & _
" (?i)(^.*?\bwarning\b.*?www\.jennycraig\.com\.au.*?$)}" & @CRLF & _
"catch_all : False" & @CRLF & _
"advanced_condition : {}" & @CRLF & _
"actions : {route PVG22KK, severity warning}" & @CRLF & _
"" & @CRLF & _
"isDraggingObject : True" & @CRLF & _
"id : 3b5aa785-b854-4e43-900a-225da5786a27" & @CRLF & _
"condition : {or, matches System.Object[] " & @CRLF & _
" (?i)(^.*?\bcritical\b.*?www\.jennycraig\.com\.au.*?$)}" & @CRLF & _
"catch_all : False" & @CRLF & _
"advanced_condition : {}" & @CRLF & _
"actions : {severity critical, route PVG22KK}" & @CRLF & _
"" & @CRLF & _
"**isDraggingObject : True" & @CRLF & _
"id : a8420998-fbca-486b-9ff7-d03b9e16536e" & @CRLF & _
"condition : {or, matches System.Object[] (?i)(^.*?\bcritical\b.*?www\.jennycraig\.com$), " & @CRLF & _
" matches System.Object[] (?i)(^.*?\bcritical\b.*?locations\.jennycraig\.com)}" & @CRLF & _
"catch_all : False" & @CRLF & _
"advanced_condition : {}" & @CRLF & _
"actions : {severity critical, route PW0VV83}**"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")