using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<event>^.\S*[^\n<]*(?:(?:<(?!)|\n(?!$))[^\n]*)*(?:|\n$|\z))";
string input = @"isDraggingObject : True
id : afbbdeb7-9fd4-4b53-ab17-742809154ba9
condition : {or, matches System.Object[] (?i)(^.*?host failure
alert.*?www\.jennycraig\.com\.au.*?$), matches System.Object[]
(?i)(^.*?\bwarning\b.*?www\.jennycraig\.com\.au.*?$)}
catch_all : False
advanced_condition : {}
actions : {route PVG22KK, severity warning}
isDraggingObject : True
id : 3b5aa785-b854-4e43-900a-225da5786a27
condition : {or, matches System.Object[]
(?i)(^.*?\bcritical\b.*?www\.jennycraig\.com\.au.*?$)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PVG22KK}
**isDraggingObject : True
id : a8420998-fbca-486b-9ff7-d03b9e16536e
condition : {or, matches System.Object[] (?i)(^.*?\bcritical\b.*?www\.jennycraig\.com$),
matches System.Object[] (?i)(^.*?\bcritical\b.*?locations\.jennycraig\.com)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PW0VV83}**";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}