const regex = /(?<event>^.\S*[^\n<]*(?:(?:<(?!)|\n(?!$))[^\n]*)*(?:|\n$|\z))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<event>^.\\S*[^\\n<]*(?:(?:<(?!)|\\n(?!$))[^\\n]*)*(?:|\\n$|\\z))', 'gm')
const str = `isDraggingObject : True
id : afbbdeb7-9fd4-4b53-ab17-742809154ba9
condition : {or, matches System.Object[] (?i)(^.*?host failure
alert.*?www\\.jennycraig\\.com\\.au.*?\$), matches System.Object[]
(?i)(^.*?\\bwarning\\b.*?www\\.jennycraig\\.com\\.au.*?\$)}
catch_all : False
advanced_condition : {}
actions : {route PVG22KK, severity warning}
isDraggingObject : True
id : 3b5aa785-b854-4e43-900a-225da5786a27
condition : {or, matches System.Object[]
(?i)(^.*?\\bcritical\\b.*?www\\.jennycraig\\.com\\.au.*?\$)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PVG22KK}
**isDraggingObject : True
id : a8420998-fbca-486b-9ff7-d03b9e16536e
condition : {or, matches System.Object[] (?i)(^.*?\\bcritical\\b.*?www\\.jennycraig\\.com\$),
matches System.Object[] (?i)(^.*?\\bcritical\\b.*?locations\\.jennycraig\\.com)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PW0VV83}**`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}