#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\.MyMethod\((?<firstParam>(?:[^(),]*|\([^)]*\))+)[,)]"
Local $sString = ".MyMethod(foo);" & @CRLF & _
".MyMethod(foo, bar);" & @CRLF & _
".MyMethod(new MyObject(1, 2), 3);" & @CRLF & _
".MyMethod(new MyObject()).MyChainedMethod();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")