package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.MyMethod\((?<firstParam>(?:[^(),]*|\([^)]*\))+)[,)]`)
var str = `.MyMethod(foo);
.MyMethod(foo, bar);
.MyMethod(new MyObject(1, 2), 3);
.MyMethod(new MyObject()).MyChainedMethod();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}