re = /\.MyMethod\((?<firstParam>(?:[^(),]*|\([^)]*\))+)[,)]/
str = '.MyMethod(foo);
.MyMethod(foo, bar);
.MyMethod(new MyObject(1, 2), 3);
.MyMethod(new MyObject()).MyChainedMethod();'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end