import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.MyMethod\\((?<firstParam>(?:[^(),]*|\\([^)]*\\))+)[,)]";
final String string = ".MyMethod(foo);\n"
+ ".MyMethod(foo, bar);\n"
+ ".MyMethod(new MyObject(1, 2), 3);\n"
+ ".MyMethod(new MyObject()).MyChainedMethod();";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}