$re = '/\.MyMethod\((?<firstParam>(?:[^(),]*|\([^)]*\))+)[,)]/';
$str = '.MyMethod(foo);
.MyMethod(foo, bar);
.MyMethod(new MyObject(1, 2), 3);
.MyMethod(new MyObject()).MyChainedMethod();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);