# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^\\/]*\\/[^\\/]*\\/).*/\1/gm;t' <<< "url.com/folder1/xxx/index.html
url.com/folder2/
url.com/folder3/xxx/yyyy/index.html
url.com/folder4/zzz/aaa/bbb/index.html"