re = /^([^\/]*\/[^\/]*\/).*/m
str = 'url.com/folder1/xxx/index.html
url.com/folder2/
url.com/folder3/xxx/yyyy/index.html
url.com/folder4/zzz/aaa/bbb/index.html'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result