package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\/]*\/[^\/]*\/).*`)
var str = `url.com/folder1/xxx/index.html
url.com/folder2/
url.com/folder3/xxx/yyyy/index.html
url.com/folder4/zzz/aaa/bbb/index.html`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}