const regex = /^([^\/]*\/[^\/]*\/).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\\/]*\\\/[^\\\/]*\\\/).*', 'gm')
const str = `url.com/folder1/xxx/index.html
url.com/folder2/
url.com/folder3/xxx/yyyy/index.html
url.com/folder4/zzz/aaa/bbb/index.html`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);