import re
regex = re.compile(r"^([^\/]*\/[^\/]*\/).*", flags=re.MULTILINE)
test_str = ("url.com/folder1/xxx/index.html\n"
"url.com/folder2/\n"
"url.com/folder3/xxx/yyyy/index.html\n"
"url.com/folder4/zzz/aaa/bbb/index.html")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)