import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([-\\d.]+[\\/\\+\\-\\*\\^\\%\\!\\&\\|]{1,2}[-\\d.]+)+$";
final String string = "ne*t\n"
+ "1*1\n"
+ "1*.5\n"
+ "1.5*2.5\n"
+ "-1.5*-2.5\n"
+ "1.5*2.5*3.5*4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}