$re = '/^([-\d.]+[\/\+\-\*\^\%\!\&\|]{1,2}[-\d.]+)+$/m';
$str = 'ne*t
1*1
1*.5
1.5*2.5
-1.5*-2.5
1.5*2.5*3.5*4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);