const regex = /^([-\d.]+[\/\+\-\*\^\%\!\&\|]{1,2}[-\d.]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([-\\d.]+[\\\/\\+\\-\\*\\^\\%\\!\\&\\|]{1,2}[-\\d.]+)+$', 'gm')
const str = `ne*t
1*1
1*.5
1.5*2.5
-1.5*-2.5
1.5*2.5*3.5*4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}