import re
regex = re.compile(r"^([-\d.]+[\/\+\-\*\^\%\!\&\|]{1,2}[-\d.]+)+$", flags=re.MULTILINE)
test_str = ("ne*t\n"
"1*1\n"
"1*.5\n"
"1.5*2.5\n"
"-1.5*-2.5\n"
"1.5*2.5*3.5*4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")