re = /^([-\d.]+[\/\+\-\*\^\%\!\&\|]{1,2}[-\d.]+)+$/m
str = 'ne*t
1*1
1*.5
1.5*2.5
-1.5*-2.5
1.5*2.5*3.5*4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end