#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[+-][0-9]{2}:[0-9]{2}\b"
Local $sString = "-23:52"
Local $sSubst = "+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)