$re = '/[+-][0-9]{2}:[0-9]{2}\b/';
$str = '-23:52';
$subst = "+";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;