const regex = /[+-][0-9]{2}:[0-9]{2}\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+-][0-9]{2}:[0-9]{2}\\b', '')
const str = `-23:52`;
const subst = `+`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);