use strict;
my $str = '-23:52';
my $regex = qr/[+-][0-9]{2}:[0-9]{2}\b/p;
my $subst = '+';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";