#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<(a|h1)[^\>]*?>(some)[^\<]*?<\/\1>"
Local $sString = "<p>" & @CRLF & _
" <h1>Some header, which I don't want to match</h1>" & @CRLF & _
" Some text - match it." & @CRLF & _
" <a href="some-file.html">Some link. Don't match neither href nor link text.</a>" & @CRLF & _
" <span>Some word, which needs to be matched</span>" & @CRLF & _
"</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")