use strict;
my $str = '<p>
<h1>Some header, which I don\'t want to match</h1>
Some text - match it.
<a href="some-file.html">Some link. Don\'t match neither href nor link text.</a>
<span>Some word, which needs to be matched</span>
</p>';
my $regex = qr/<(a|h1)[^\>]*?>(some)[^\<]*?<\/\1>/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}