const regex = /<(a|h1)[^\>]*?>(some)[^\<]*?<\/\1>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(a|h1)[^\\>]*?>(some)[^\\<]*?<\\\/\\1>', 'gmi')
const str = `<p>
<h1>Some header, which I don't want to match</h1>
Some text - match it.
<a href="some-file.html">Some link. Don't match neither href nor link text.</a>
<span>Some word, which needs to be matched</span>
</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}