using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-9]{1,3}(?:,[0-9]{3})*)?\.[0-9]{2}$";
string input = @"Allow
100,000.12
10,000.12
1,000.12
100.12
10.12
.12
Don't allow
abcd
1,,000.12
1,00.12
1,000.0
1,000.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}