use strict;
my $str = 'Allow
100,000.12
10,000.12
1,000.12
100.12
10.12
.12
Don\'t allow
abcd
1,,000.12
1,00.12
1,000.0
1,000.';
my $regex = qr/^(?:[0-9]{1,3}(?:,[0-9]{3})*)?\.[0-9]{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}