// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[0-9]{1,3}(?:,[0-9]{3})*)?\.[0-9]{2}$").unwrap();
let string = "Allow
100,000.12
10,000.12
1,000.12
100.12
10.12
.12
Don't allow
abcd
1,,000.12
1,00.12
1,000.0
1,000.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}