const regex = /^(?:[0-9]{1,3}(?:,[0-9]{3})*)?\.[0-9]{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9]{1,3}(?:,[0-9]{3})*)?\\.[0-9]{2}$', 'gm')
const str = `Allow
100,000.12
10,000.12
1,000.12
100.12
10.12
.12
Don't allow
abcd
1,,000.12
1,00.12
1,000.0
1,000.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}