import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]{1,3}(?:,[0-9]{3})*)?\\.[0-9]{2}$";
final String string = "Allow\n\n"
+ "100,000.12\n\n"
+ "10,000.12\n\n"
+ "1,000.12\n\n"
+ "100.12\n\n"
+ "10.12\n\n"
+ ".12\n\n"
+ "Don't allow\n\n"
+ "abcd\n\n"
+ "1,,000.12\n\n"
+ "1,00.12\n\n"
+ "1,000.0\n\n"
+ "1,000.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}