const regex = new RegExp('(?:(?<!\\w)[?!,])|(?:[?!,](?!\\w))', 'gm')
const str = `?hello !mango! and, ban,ana yum apple!`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);