$re = '/(?:(?<!\w)[?!,])|(?:[?!,](?!\w))/m';
$str = '?hello !mango! and, ban,ana yum apple!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;