import re
regex = re.compile(r"(?:(?<!\w)[?!,])|(?:[?!,](?!\w))", flags=re.MULTILINE)
test_str = "?hello !mango! and, ban,ana yum apple!"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)