re = /(?:(?<!\w)[?!,])|(?:[?!,](?!\w))/m
str = '?hello !mango! and, ban,ana yum apple!'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result