#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:src=\")(?P<URL>.*)\""
Local $sString = "![enter image description here][1] [1]: <img src="http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")