// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:src=\")(?P<URL>.*)\""#).unwrap();
let string = "![enter image description here][1] [1]: <img src=\"http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png\" />";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}