$re = '/(?:src=\")(?P<URL>.*)\"/';
$str = '![enter image description here][1] [1]: <img src="http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png" />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);