import Foundation
let pattern = #"(?:src=\")(?P<URL>.*)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"![enter image description here][1] [1]: <img src="http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png" />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}