using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:src=\"")(?P<URL>.*)\""";
string input = @"![enter image description here][1] [1]: <img src=""http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png"" />";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}