package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([a-zA-Z0-9#&()-:"',.\/°äÄÖöüÜßáéíóúüñ¿¡ ]*)$`)
var str = `{TEST}
hi {} {TEST}
TEST
BEST
{} {FEST
bla {} hi {} TEST} {}
bla {} hi {} {TEST {}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}