re = /^([a-zA-Z0-9#&()-:"',.\/°äÄÖöüÜßáéíóúüñ¿¡ ]*)$/im
str = '{TEST}
hi {} {TEST}
TEST
BEST
{} {FEST
bla {} hi {} TEST} {}
bla {} hi {} {TEST {}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end