// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)^([a-zA-Z0-9#&()-:"',.\/°äÄÖöüÜßáéíóúüñ¿¡ ]*)$"#).unwrap();
let string = "{TEST}
hi {} {TEST}
TEST
BEST
{} {FEST
bla {} hi {} TEST} {}
bla {} hi {} {TEST {}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}