import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9#&()-:\"',.\\/°äÄÖöüÜßáéíóúüñ¿¡ ]*)$";
final String string = "{TEST}\n"
+ "hi {} {TEST}\n\n"
+ "TEST\n"
+ "BEST\n"
+ "{} {FEST\n"
+ "bla {} hi {} TEST} {}\n"
+ "bla {} hi {} {TEST {}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}