$re = '/^([a-zA-Z0-9#&()-:"\',.\/°äÄÖöüÜßáéíóúüñ¿¡ ]*)$/im';
$str = '{TEST}
hi {} {TEST}
TEST
BEST
{} {FEST
bla {} hi {} TEST} {}
bla {} hi {} {TEST {}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);