using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"factType=(?<facttype>\w+).+filters=(?<filters>[^\&]+)";
string input = @"msg: abc.asia - [2021-08-23T00:27:08.152+0000] ""GET /facts?factType=COMMERCIAL&aaa=2021-08-23T00:27:08.152+00002021-08-23T00:27:08.152+0000&filters=abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}