const regex = /factType=(?<facttype>\w+).+filters=(?<filters>[^\&]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('factType=(?<facttype>\\w+).+filters=(?<filters>[^\\&]+)', 'gm')
const str = `msg: abc.asia - [2021-08-23T00:27:08.152+0000] "GET /facts?factType=COMMERCIAL&aaa=2021-08-23T00:27:08.152+00002021-08-23T00:27:08.152+0000&filters=abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}